Tektronix P6042 Current Probe

Vorstellung, Diskussion, Restauration
Antworten
JanW
Beiträge: 57
Registriert: 01 Jun 2019, 00:54
Wohnort: Erftstadt

Tektronix P6042 Current Probe

Beitrag von JanW » 11 Jan 2020, 22:26

Hallo zusammen!

Gerade liegt eine P6042 Stromzange von Tektronix auf dem OP-Tisch. Ich habe das Teil vor 2-3 Jahren bei Ebay ersteigert, irgendwie hatte ich Glück, es war relativ günstig. Als es dann ankam, war es jedoch defekt. Das Ausgangssignal zeigt einen starken Offset.

Die Vorbesitzer haben eine bedruckte Aluplatte mit einer Kurzanleitung aufgeklebt, an der der Zahn der Zeit hässliche Spuren hinterlassen hat. Schade. Eine Demontage wird jedoch das Gehäuse beschädigen, daher lasse ich das vergilbte Ding lieber drauf.
20200111_220205-768x1024.jpg
20200111_220205-768x1024.jpg (172.19 KiB) 4010 mal betrachtet
Das Ding ist aus Zeiten, als Rohde & Schwarz noch der Tektronixvertrieb in Deutschland waren:
20200111_220035-768x1024.jpg
20200111_220035-768x1024.jpg (139.29 KiB) 4010 mal betrachtet
Ich habe das kleine Kistchen aufgemacht und die gewönhlichen Tests gemacht (optische Inspektion, Versorgungsspannungen gemessen, Ripple bestimmt). Obwohl die Kondensatoren einen 1967er Datecode haben, ist alles in Ordnung.
20200111_220042-768x576.jpg
20200111_220042-768x576.jpg (172.84 KiB) 4010 mal betrachtet
20200111_220021-768x1024.jpg
20200111_220021-768x1024.jpg (239.63 KiB) 4010 mal betrachtet
Ich habe ein wenig an den (allesamt gesockelten) Transistoren herumgewackelt und vor allem bei den thermisch gekoppelten Transistoren Q96 und Q87 kam es zu einem deutlichen Ausschlag auf dem Oszi.
Nach dem Putzen der Transistorbeinchen und dem erneuten Einstecken läuft das Teil wieder. Das Tek 7904 dient mit seinem Kalibrator als Stromquelle, das Tek 2465CTS zeigt das Ausgangssignal an:
20200111_220149-768x1024.jpg
20200111_220149-768x1024.jpg (265.22 KiB) 4010 mal betrachtet
20200111_220142-768x1024.jpg
20200111_220142-768x1024.jpg (198.53 KiB) 4010 mal betrachtet
Jetzt muss ich nur noch den Frequenzgang kompensieren . . .

Gruß,

Jan
Dateianhänge
20200111_220031-768x1024.jpg
20200111_220031-768x1024.jpg (221.64 KiB) 4010 mal betrachtet
IMG-20200111-WA0006-768x1365.jpeg
IMG-20200111-WA0006-768x1365.jpeg (256.89 KiB) 4010 mal betrachtet

Martin
Site Admin
Beiträge: 455
Registriert: 08 Dez 2018, 19:26

Re: Tektronix P6042 Current Probe

Beitrag von Martin » 12 Jan 2020, 07:31

hallo Jan,

klasse das Teil.
Ich hab hier eine da ist die Zange selbst seitlich angerauht vom vielen rein- und rausschieben und such noch nach einer praktikablen Methode um das Bakelit oder was es auch sein mag wieder schön schwarz-glänzend hinzubekommen.
Wirklich interessant wirds wenn wir die mal bei 10MHz einem Test unterziehen.

lG Martin

Benutzeravatar
ProgBernie
Beiträge: 149
Registriert: 19 Dez 2018, 22:49

Re: Tektronix P6042 Current Probe

Beitrag von ProgBernie » 12 Jan 2020, 14:12

Ja, so ein P6042 könnte ich auch noch gut gebrauchen.
Die Aluplatte sieht so aus als wäre das eine die mit diesem Photoverfahren von Seno? verarbeitet worden ist.
Gruß Bernd

Benutzeravatar
Matt
Beiträge: 275
Registriert: 08 Dez 2018, 19:41

Re: Tektronix P6042 Current Probe

Beitrag von Matt » 12 Jan 2020, 14:17

Ich habe Nachfolger A6303 mit AM503, aber ich nutze den kaum, öfter wird AC-Zange dafür genutzt, da ich oft nur Wechselspannung messen wollte.

Aluplatte, kommt drauf, wie es geklebt wird. Machmal greife ich zu Heissluftgerät und erwärme ihm so weit, dass Klebenstelle aufgibt.

Grüss
Matt

JanW
Beiträge: 57
Registriert: 01 Jun 2019, 00:54
Wohnort: Erftstadt

Re: Tektronix P6042 Current Probe

Beitrag von JanW » 13 Jan 2020, 10:41

Irgendwie driftet die Ausgangsspannung langsam über die Zeit, und zwar in beide Richtungen, mit einer sehr langsamen Weise, ohne Periodizität. Ist das normal?

Gruß,

Jan

Stefan564B
Beiträge: 14
Registriert: 10 Dez 2018, 14:40

Re: Tektronix P6042 Current Probe

Beitrag von Stefan564B » 13 Jan 2020, 16:59

Hallo Jan,

hast du die Stromzange mal entmagnetisiert? -> in die Aufnahme stecken und Degauss betätigen.

Da die Zange auch DC kann reicht ein Permanentmagnet in der Nähe um das Signal driften zulassen.
Ich habe das gleiche Gerät, müsste ich mal anschließen und testen, ich meine aber bei mir war es auch so.

Gruß Stefan

JanW
Beiträge: 57
Registriert: 01 Jun 2019, 00:54
Wohnort: Erftstadt

Re: Tektronix P6042 Current Probe

Beitrag von JanW » 13 Jan 2020, 17:28

Tatsächlich bessert es sich nach dem Entmagnetisieren. Ich bin nur erstaunt, wie schnell sich wieder ein Magnetfeld aufbaut, obwohl das Gerät derzeit nur AC misst.

Gruß,

Jan

Benutzeravatar
Matt
Beiträge: 275
Registriert: 08 Dez 2018, 19:41

Re: Tektronix P6042 Current Probe

Beitrag von Matt » 13 Jan 2020, 20:36

Vergiss bitte nicht: Wechselspannung ist nicht perfekt, hat sowieso minimale DC-Offset.

Grüss
matt

chronos42
Beiträge: 54
Registriert: 14 Dez 2018, 19:36
Wohnort: Karlsruhe

Re: Tektronix P6042 Current Probe

Beitrag von chronos42 » 21 Mär 2020, 13:36

Hallo zusammen,
bei der P6042 ist es überlebenswichtig die Stromzange sorgfältigst und mit größter Vorsicht zu behandeln. Schon ein kleiner Schlag kann dazu führen dass im Ferritkern Mikrorisse entstehen. Die P6042 ist dann komplett unbrauchbar. Ich habe zwei P6042 mit defektem Messkopf, die leider nur noch als Teilespender für die Elektronik dienen. Die Messköpfe waren nicht mehr zu retten. Haarrisse zeigen sich in extremen Offset und Amplitudenschwankungen bei der geringsten bewegung der Zange. Eine dritte funktioniert hingegen perfekt nach Reinigen der Kontakte und Potis.

Also:
Stöße unbedingt vermeiden.
Die Flächen der beiden Magnetkerne NIEMALS mit irgendwelchen Flüssigkeiten reinigen.

Ein weiterer Schwachpunkt ist das Kabel zur Stromzange, bei diesem brechen immer wieder einzelne Adern an der Stelle, wo es in das Gehäuse geht. Das Kabel ist eine Spezalanfertigung von Tek und eigentlich nicht zu ersetzen. Es hilft nur das defekte Stück so kurz wie möglich herauszutrennen, was ich bei meiner 6042 auch machen musste. Die Kabel sind nun über 50 Jahre alt und der Kunststoff ist mittlerweile versprödet, was die Bruchgefahr deutlich erhöht. Also auch das Kabel vorsichtig behandeln und möglicht wenig bewegen, vor allem im Bereich der Gehäusezuführung.

Wie Jan auch schon geschrieben hat sind die alten Elkos dieser Geräte problemlos. Ich wollte die bei meinem Gerät ursprünglich auch wechseln, aber es gibt einfach keinen Grund dafür. Sowohl die Kapazität als auch der ESR sind im grünen Bereich. Zudem sind einige der Elkos nur mit großem Aufwand zu wechseln, bei einigen geht das nur wenn das komplette Mainboard ausgebaut ist. Aufgrund der Verkabelung ist das eine sehr unschöne Sache, viele Tek Geräte aus dieser Zeit waren alles andere als servicefreundlich, ganz im Gegenteil, sie waren oft extrem verbaut. Das sollte man bei aller (berechtigten) Verklärung dieser Tek Geräte auch mal ganz objektiv sehen.

Einige der selektierten Transistoren und das von Tek gefertigte IC im Eingangsbereich sind kaum noch beschaffbar. Da ich zwei unreparierbare Schlachtgeräte habe kann ich von einem diese Teile abgegeben für den Fall, dass jemand dringenden Bedarf hat und ein P6042 retten möchte. Aber bitte nur in diesem Fall anfragen und nicht um es mal auf Vorrat in eine Schublade zu legen.

Ich habe auch eine moderne TCP202, die Stromzange selbst basiert immer noch auf derselben Konstruktion wie die P6042. Sie wird direkt an die digitalen Geräte mit Tekprobe Schnittstelle angeschlossen. Hört sich gut an, ist auch praktisch aber: Die 6042 ist das bessere Gerät bezüglich Empfindlichkeit. Die P6042 ist da um den Faktor 10 besser, dieTCP202 kann nicht mal das Referenzsignal eines PG 506 Kalibrators von 5mA brauchbar darstellen. Für kleine Signale nehme ich deswegen immer noch die 6042. Alles andere ist bei der modernen TCP202 allerdings besser, das Handling, die Drift und die korrekte Anzeige im Oszilloskop in mA oder A.

Antworten