| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

Wellenkino.de Forum (deutsch + englisch)

TDS540 mit Elkopest
  •  
 1 2
26.01.18 20:30
Matt 

Administrator

Re: TDS540 mit Elkopest

Jap, leider ist differentielle ECL an Ausgang von Komparator in Ordnung . U1001 (CTL) ebenso.
Trigger C und D hatte ich noch nicht untergesucht, sollte aber nicht daran liegen, denn der wird für Logik-Trigger genutzt.

Fairweise müsste ich sagen, dass ich nicht beide Ausgang gleichzeitig gemesst habe. Wenn differentielle Ausgang Rechteck in Gleichtakt raushaut, dann sollte man nicht wundern, dass CTL ihm nicht verarbeitet.

Eine Auffälligkeit: wenn ich auf "Trigger Level Set to 50%" drücke, dann ist maximale negative Spannung als Trigger-Pegel.


Bei Extremfall bleibt mir nur Vergleichmessung mit TDS520.
Hattest du schon "Slow Trigger Logik " (U1050, ADG225C) als Fehlerursache gehabt ?
Ist möglich, dass kaputte SRAM auch Triggerproblem verursacht ...ich kann irgendwie nicht vorstellen.


Übrigends, ich habe heute eine weitere Unterbrechung gefundet, an Spannungsteiler für Komparator LM311 (U1603). Damit ist es auf 2 Unterbrechung hochgezählt.

Grüss
Matt

26.01.18 20:47
chronos42 
Re: TDS540 mit Elkopest

Defektes SRAM kann eigentlich keine Triggerprobleme verursachen.
Das Triggerereignis wird von dem Array in den Datenstrom und somit in das ACQ RAM geschrieben. Aber wenn das prinzipiell mit den anderen Kanälen funktioniert muss da was an der Übertragung der Triggerdaten von Kanal 3 falsch laufen, sonst würde gar nichts triggern
Es könnte auch ein Problem in Verbindung mit U 1050 vorliegen, der das ECL Array konfiguriert.
Aber so richtig erklären kann ich mir das zur Zeit auch nicht.

Ich bin mir auch nicht sicher ob Trigger C und D wirklich nur für den Logic Trigger verwendet werden. Je nach Betriebsart kann da eventuell alles mögliche benutzt werden. Ist bei den ADCs auch so, ADC A ist nicht unbedingt immer Kanal 1 zugeordnet, das ist alles sehr flexibel. Aber da muss ich auch noch mal in den Unterlagen nachschauen

Aber wie gesagt, da habe ich jetzt auch keine schnelle Antwort bereit.

Ist das Triggersignal so einstellbar, dass es einigermaßen in der Mitte der Triggereinstellung erzeugt wird (bei manueller Einstellung des Triggerpegels) oder liegt das auch völlig daneben? SPC hast Du mal gemacht?

Zuletzt bearbeitet am 26.01.18 20:49

14.02.18 17:35
Matt 

Administrator

Re: TDS540 mit Elkopest

Moin

Heute hatte ich weiter mit TDS540 gemacht, nachdem TDS520 mich eher nur Rästel aufgibt (STRIGA) und ich keine Ansatz mehr habe, wo ich es suchen könnte. Hatte sogar CPU Board in Verdacht gehabt (Timer) allerdings macht TDS540 genauso mit Mäuse-Klavier-Einstellung (1000 0000, der angeblich Timer testet )

Seit eben gibt er eine Fehlermeldung weniger aus.
Eine SRAM ist kaputt und andere SRAM ist wegen Unterbrechung nicht richtig angesteuert.
An eine weitere SRAM gab Lötfehler ( feine Spritzer, ich habe komplett SRAM-Satz (32 Stück) runtergelötet & geputzt)

Damit zählt Unterbrechung auf 3 hoch.

Dann müsste ich schauen, was SDUT und SMUT gemeint ist.



BTW. SPC ist auf Kanal bezogen fehlerfrei. Es ist wie erwartet, dass Trigger Problem macht.
Zu deine Frage mit Trigger-Pegel, es ist sogar pausibel (leichte Offset und Abweichung, aber das ist trotzdem theoretisch in Ordnung)


Grüss
Matt

Datei-Anhänge
IMG_20180214_171554.jpg IMG_20180214_171554.jpg (19x)

Mime-Type: image/jpeg, 172 kB

IMG_20180214_171621.jpg IMG_20180214_171621.jpg (18x)

Mime-Type: image/jpeg, 192 kB

14.02.18 17:41
Matt 

Administrator

Re: TDS540 mit Elkopest

EDIT: eben in Plan gefundet SMUT& SDUT , das ist berühmte STRIGA und STRIGB. *kotz*



Grüss
Matt

Datei-Anhänge
smut_sdut.png smut_sdut.png (19x)

Mime-Type: image/png, 162 kB

17.02.18 11:17
Matt 

Administrator

Re: TDS540 mit Elkopest

Ich weiss nicht warum habe ich angefangen in Holdoff-Schaltung rumgestochert.
Vermutlich weil ihre Flipflop fast keine Reaktion zeigt. (hat nur eine Pegelwechsel beim Hochlauf gemacht, das war)

Und das ist genau richtige Ziel. Eine Unterbrechung ist gefundet und überbrückt.

JA! Das ist SUPER.



Grüss
Matt

Datei-Anhänge
IMG_20180217_111118.jpg IMG_20180217_111118.jpg (20x)

Mime-Type: image/jpeg, 277 kB

17.02.18 16:27
chronos42 
Re: TDS540 mit Elkopest

Hallo Matt,

das trifft sich gut, gerade habe ich Dir per PM geschrieben, dass Du die holdoff Schaltung untersuchen sollst...

Das hatte ich auch schon bei einem 540. Die nicht funktionierende holdoff Schaltung verhindert das Triggern zuverlässig.

Gruß

KL

17.02.18 17:18
Matt 

Administrator

Re: TDS540 mit Elkopest

Ja , schöne Ironie, aber du hast mit Holdoff-Schaltung richtig gedachtet.


(Nicht in Bild: defekte CPU Board und funktionsfähige Firmwareboard)

Nicht wenige IC ist TTL von CPU Board. (Gammel durch Elektrolyt)


Noch ist es mit ihm nicht fertig, volle Neuabgleich ist notwendig. Alte NVSRAM Inhalt ist wie bereits geschrieben dermass korrupt.

Grüss
Matt

Datei-Anhänge
IMG_20180217_144022.jpg IMG_20180217_144022.jpg (18x)

Mime-Type: image/jpeg, 1.038 kB

13.05.18 20:48
Matt 

Administrator

Re: TDS540 mit Elkopest

Moin

Nicht unbedingt neues gibt es.


Mit Neuabgleich scheiterte ich immernoch: wenn ich bestimmte Spannung einspeisen , der mit 5,5 Stellige DMM verifiziert ist (auf 0,1% Toleranz eingestellt) Dann meckert Abgleichprogramm, dass Spannung falsch ist, ich muss da also dermass hinbiegen, dass der Tek am Ende annihmt, dafür ist Spannungswert ganz falsch , trotzdem bricht Abgleichsoftware mit Fehlermeldung ab (was genau habe ich inzwischend vergessen)

Ich habe also 2 Wahl: mit derzeitige Abweichung (ca 1% ) leben oder 5% Abweichung mit Fehlermeldung.
Da hab ich natürlich Lust daran verloren und für 1% Abweichung entschieden und was müsste ich sagen?

Der TDS540 läuft stabil, stabil !



Genauso schaut mit TDS520 aus, der weiterhin Fehlermeldung mit Pulstrigger wirft. Diese Tek ist inzwischend bei eine Student verliehen und der nutzt weiterhin. Auf meine Nachfrage, wie es geht:übliche Fehlermeldung, sonst stabil.

Somit ist Reparatur auf Kompomentebene bei TDS540 abgeschlossen, aber so richtig froh bin ich nicht (Softwareabgleich)

Grüss
Matt

14.05.18 17:43
chronos42 
Re: TDS540 mit Elkopest

Hallo Matt,

Das Problem mit den nicht abgleichbaren Referenzspannungen hatte ich auch schon. Ursache war ein kleines Hybrid im SO8 Gehäuse. Das gibt es in zwei Bauformen. Einmal als keramischer Widerstandhybrid, welcher mit etwas Abstand auf das Board aufgelötet ist. Die zweite Bauform sieht aus wie ein SO8 IC. Diese Bauform ist besonders anfällig gegen Elektrolyt. Beim Abgleich werden die internen Referenzspannungen gegen die extern angelegten überprüft und ein Korrekturfaktor berechnet. Ist dieser zu groß, weil z.B. das Hybrid aufgrund von eingedrungenem Elektrolyt aus der Toleranz ist, kommt es zu dieser Fehlermeldung. Die zulässigen Toleranzen sind wohl sehr klein, ich musste deswegen schon zwei Hybride austauschen. Zudem sind die kontaminierten Hybride auch recht temperaturabhängig. Leider ist mein Vorrat aus den Schlachtboards aufgebraucht, ich habe also derzeit kein passendes Ersatzteil, mit dem Du überprüfen kannst, ob es daran liegt.

PS: Die blaue Markierung im Schaltplanausschnitt ist natürlich falsch, gemeint ist das Netzwerk links von dem Analogschalter. Der markierte Analogschalter ist aber auch ein Kandidat für solche Probleme.

Gruß

KL

Zuletzt bearbeitet am 14.05.18 18:17

Datei-Anhänge
RNET.jpg RNET.jpg (15x)

Mime-Type: image/jpeg, 87 kB

14.05.18 18:04
Matt 

Administrator

Re: TDS540 mit Elkopest

In diese TDS540 ist Plastikversion verbaut.
Das trifft gut, dass Widerstandwert in TDS544A Manual (diese Bild stammt von dort) gekritzelt ist und ich es an vorhandene Exemplare nachprüfen kann. Temperaturgang ist bei diese Widerstandnetzwerk auch schon wichtig.

Wenigsten müsste man nicht ultraschnelle Logikelement nachbauen, sondern nur eine "simple" Widerstandnetzwerk.

Bei TDS540 war ich nicht rigoros mit Bauteile-Tausch, da es in deutlich bessere Zustand als TDS520 ist.
Trotzdem sehen 4 Augen besser und mehr als allein.

Das wird eine Winterprojekt sein,denn in Sommerzeit widme ich Zeit mehr zu meine Zweitwagen (aktuell will der neue 6x Zündspule haben) und meine Gesundheit.



Grüss
Matt

 1 2
Triggerkomparatoren   Mäuse-Klavier-Einstellung   Triggerkomparators   Holdoff-Schaltung   Widerstandkodierung   Referenzspannungen   Fehlermeldung   Unterbrechung   Firmware-Board   Triggereinstellung   Firmwareboard   funktionstüchtige   Fehlermeldungen   Ansteuerungsproblem   Trigger-Fehlermeldung   Maskenprogrammierung   Widerstandnetzwerk   Schaltplanausschnitt   temperaturabhängig   Elkopest