| Passwort vergessen?
Sie sind nicht angemeldet.  Anmelden

Sprache auswählen:

Wellenkino.de Forum (deutsch + englisch)

Tektronix TDS520 und ihre Elko-Pest
  •  
 1 2 3 4 5
26.12.17 17:37
Matt 

Administrator

Tektronix TDS520 und ihre Elko-Pest

Hallo liebes Leute

Ich habe über Umstände für kleine Preis ihm ergattert. Von ihre Verpackung rede wir besser nicht (Presspassung in Karton)

Fehler ist allbekannte ACQ-FAIL. Diese Fehlermeldung kommt erst, wenn Elko-Pisse durch Leiterbahnen geätzt ist, sodass es unterbrochen ist, was falsche ADC-Arbeitspunkt bedeutet. Dass Fehlermeldung erst auffällt, wenn Leiterbahnen gebrochen ist, wisst meiste nicht.

Deshalb reicht NIE reine Elko-Kur aus. Denn es müsste nach Leiterbahnenunterbrechung gesucht werden .



Allererste habe ich alle SMD Elko auf ACQ-Board rausgelötet und gewascht (SEHR wichtig wegen ausgelaufene Eletrolyt )
Dann habe ich einige IC erneuert und hofft dass andere korrodierte IC noch ihre Dienst tuen, denn ich habe nicht alle IC auf Lager.

Mindenst 10x Leiterbahnen-Unterbrechung entdeckt und geflickt.. schlimmsten hat es VCO getroffen.

Meine aktuelle Stand:
Trigger auf alle Kanal und beide Kanal funktioniert, wobei beide Kanal noch Offset hat (der per SPC nicht weggerechnet werden könnte)
Dazu schwingt es und schmiert Bildschirm, wenn ich es unterhalb Mittellinie verschiebt.

Vielleicht kennt ihr Fehler und kann mich genauerer hinweisen.

Morgen wird MC34002 und LM311 und paar IC gegen gleichwertige & neuwertige IC ausgetauscht.
Hälfte TL074 ist bereits durch LMC6484 getauscht.


Grüss
Matt

PS: Kleine Trostpreis: TDS520 Schaltplan ist in Website zu finden.
PSS: Wenn ich wüsste, dass Vorbesittzer mit Reparatur an ihm angefangen haben, würde nichtmal annehmen. Denn ich habe mit ihre Arbeit rumgeplagt: Frontpanel , alle Elko und korrodierte Bauteile wurde entfernt, aber nicht wieder bestückt. Sodass mich ab und zu mit verschluckte Eingabe ärgert. Es wurde nur wegen nichtfunktionierte Kalibrator-Ausgang entdeckt. (ohne Schaltplan ist es verloren)

Datei-Anhänge
IMG_20171226_104240.jpg IMG_20171226_104240.jpg (18x)

Mime-Type: image/jpeg, 1.129 kB

27.12.17 18:37
Matt 

Administrator

Re: Tektronix TDS520 und ihre Elko-Pest

Hallo Leute


Heute gibt grosse Fortschritte nach aufwändige Produzeur: alle gammelige Teile auslöten, Platine putzen und ggf. (habe nicht alles auf Lager) wiederverwenden. Dabei ist 3 weitere Unterbrechung entdeckt.



Dann gibt bei Wiederinbetriebnahme grosse GAU: fast alle OPV an +-15V wird extrem heiss. Ich habe Ursache richtig schnell erkannt: "latch up" (Bitte lies es beim Wikipedia)
Hauptursache: eine OPV hat nicht -15V bekommt und schlägt auf andere OPV durch und zündet ihm.

Nach fädeln von Betriebsspannung an OPV sollte Problem gelöst sein. Leider hat nicht alle OPV überlebt und mir ist OPV ausgegangen. Ich habe mit Zähneknirschen oxidierte OPV aus Müll gekramt und eingelötet.


GROSSE Erfreunisse: Kanal 1 ist ohne Problem. Kanal 2 ist funktionstüchtig und hat immernoch mit Offset. (ich habe da gammelige 74HCT164 für Kanal2 in Verdacht und habe keine neue bzw. gute IC da.)



Grüss
Matt

Datei-Anhänge
IMG_20171227_182525.jpg IMG_20171227_182525.jpg (8x)

Mime-Type: image/jpeg, 601 kB

IMG_20171227_182559.jpg IMG_20171227_182559.jpg (6x)

Mime-Type: image/jpeg, 731 kB

IMG_20171227_182808.jpg IMG_20171227_182808.jpg (12x)

Mime-Type: image/jpeg, 1.791 kB

27.12.17 19:47
Matt 

Administrator

Re: Tektronix TDS520 und ihre Elko-Pest

eine neue Fehler entdeckt.. der macht ab 200ns Zeitablenkung keine bzw. nur spärliche Punkte in Darstellung.

Time -Interpolator und Jitter-Generator macht da also Problem, da ist genau Schaltungsteil, wo OPV durchgezündet wird.


Grüss
Matt

28.12.17 18:41
Matt 

Administrator

Re: Tektronix TDS520 und ihre Elko-Pest

Time-Interpolator & Jitter-Ramp-Generator ist repariert aber Darstellung bleibt beschissen.

Da war Z-Diode als Fehlerursache, Messung an Z-Diode sagt fast 10V, ist das für 5,1V-Typ in Ordnung ?
Es wird gespannt, welchere weitere Fehler ich finden werde.

Restliche überlebene OPV (MC34002 & TL074) an +-15V Schiene wird wegen Zuverlässigkeitsgründe durch TL052 erneuert.
Tausch von gammelige TL074 und 74HCT164 steht noch aus.

Grüss
Matt

03.01.18 18:54
Matt 

Administrator

Re: Tektronix TDS520 und ihre Elko-Pest

GAU.

Kanal 2, der immernoch Ärger macht.
Fehlerursache ist zu grosste Warscheinlichkeit kaputte ADC.

ADC ist mit Multiplexer über 16 Leitung verbunden, da läuft ECL Logik.
Dort sollte Spannung von -1,7V und -0,7V anliegen, bei eine Leitung hängt es dauerend an -5V und keine Kurzschluss zu -5V Betriebsspannung festgestellt.

Kanal 2 stellt schwingung dar, der nur ab bestimmte Abtastrate sichtbar ist.
Besagte Leitung schaltete ich über Widerstand an Masse und Schwingung an Bildschirm ist verschwundet.

Tja, deutliche Ergebnisse.

Letzte Hoffung: ich lötete ADC aus und schaue, ob an ADC-Substrat etwas untergebrochen ist.
Trotzallem bin ich auf Suche nach ADC aus tote ACQ Board... da winke ich zu Benedikt und cronos42 (?)

Grüss
Matt

03.01.18 19:59
Matt 

Administrator

Re: Tektronix TDS520 und ihre Elko-Pest

ADC ist ausgelötet und begutachtet.

Es stellt fest, dass ich neue ADC brauche, es ist nachgewiesen, dass ADC kaputt ist.
Diodetest an besagte Ausgang ergibt "open", intakte Ausgang hat so um 1,6V bzw. 1,1V , je nach Polarität.

Doof ist es schon.

Teilenummer : 155-0371-01

Grüss
Matt

Datei-Anhänge
IMG_20180103_194141.jpg IMG_20180103_194141.jpg (8x)

Mime-Type: image/jpeg, 1.355 kB

04.01.18 10:50
chronos42 
Re: Tektronix TDS520 und ihre Elko-Pest

Hallo Martin,

ich habe nun fast ein Dutzend TDS540 repariert, teilweise mit massivsten Schäden. In einem Extremfall war wirklich alles defekt, VCO, Clockskew-Chip Ansteuerung, bei De-Jitter Stufen, beide Triggerstufen, ca. 20 unterbrochene VIAs im Bereich der VCA Steuerung, unterbrochene Datenleitungen zwischen ADCs und ACQ Controller, komplett weggeätzte Drähte an den Drehgebern, unzählige defekte OpAmps und 4 durch Elektrolyt zerstörte ACQ Speicherchips, etc. etc. Das war eine wochenlange Reparatur durch das komplette Gerät. Das funktioniert nun wieder hervorragend und performt ausgezeichnet. (Es wurde selbstverständlich nach der Reparatur auch komplett neu abgeglichen, auf den aktuellen Softwarestand gebracht und die FFT Option freigeschaltet)

Aber einen defekten ADC hatte ich noch nie.
Ich kann bei Interesse mal bei mir im Keller nachschauen, da liegen noch verschiedene TDS Boards herum, die mal als Ersatzteilspender gekauft wurden. Der ADC des TDS540 müsste eigentlich derselbe sein wie bei den TDS 520. Da könnte ich einen spendieren.

Das Phänomen, dass nur bei bestimmten Abtastraten was dargestellt wird liegt nach meinen Erfahrungen am Chip für die Clock Verteilung. Dieses Problem kenne ich. Ursache war die Ansteuerung dieses Chips. Der Chip für die Taktverteilung ist notwendig um die ADCs mit einer präzisen Phasenlage anzusteuern. Wichtig im Sampling-Modus und wenn die beiden ADCs zusammenarbeiten. Dazu wird ein spannungsgesteuertes Delay verwendet. Das wird mit Kapazitätsdioden im Chip gemacht. Durch Fehler in der analogen Ansteuerung dieser Chips kann es sein, dass die Kapazitätsdioden nicht im Sperrbereich arbeiten sondern leiten und damit das Taktsignal sporadisch oder dauerhaft kurzschließen. Dann kommt es genau zu diesem Fehler. Alle Spannungen an diesen Chips genau überprüfen mit den Angaben im Schaltbild, vor allem die Polarität.

Zusammenfassung:

Einen ADC kann ich bestimmt spendieren.


Und falls noch jemand Interesse an einem TDS 540 hat:
Hier stehen noch zwei generalüberholte, voll funktionsfähige herum, die gerne einen neuen Besitzer haben möchten. (Beide mit der Extended Memory Option und dem Mathematikpaket, einschließlich FFT).

Für 250 Euro wechseln sie den Besitzer.

04.01.18 15:44
Matt 

Administrator

Re: Tektronix TDS520 und ihre Elko-Pest

Hallo

Ich heisse aber Matt, nicht Martin (der Chef)

Nach deine Beschreibung von Schaden durch ausgelaufene Elektrolyt müsste ich sagen, dass meine TDS520 gimpflich erwischt hatte. Auch wenn der lang auf Rückwand stand (Spuren von Elektrolyt, der auch ins ACQ Controller gelaufen ist)
Alle (ja !) Elko auf CPU Board ist intakt, weist noch gesunde Werte und stinkt NICHTS beim auslöten.

Messung spricht 100% Defekte an ADC.
Mir ist auch recht sicher, dass ADC an 520 und 540 identisch ist.

Ist es korrekt, dass beim TDS540 ADC auch 16 Leitung zwischen Multiplexer (oder wie du es nennt: ACQ Controller) besitzt und mit bis zu 250Mhz Takt in ECL Pegel bekommt, der dann auf 125Mhz Takt runtergeteilt und dann an ACQ Controller ansteuert, der ihre SRAM füllt.

Rest siehe Private Nachrichten.

Lass mich etwas dafür bezahlen.

Grüss
Matt

04.01.18 15:50
chronos42 
Re: Tektronix TDS520 und ihre Elko-Pest

Matt:
Hallo

Ich heisse aber Matt, nicht Martin (der Chef)


Ups, sorry Matt....

Ok, warte auf PM.

Ich hole den Organspender schon mal aus dem Keller und werde den ADC auslöten. Das dürfte auch für die 1000 Watt starke Rework Station nicht einfach werden.

Das mit den Frequenzen stimmt, die RAMs werden interleaf angesteuert, also zeitversetzt und mit halber Frequenz.

Zuletzt bearbeitet am 04.01.18 15:52

04.01.18 15:57
Matt 

Administrator

Re: Tektronix TDS520 und ihre Elko-Pest

Es ist einfach, schnell ins Kreis vorbei von Kühler an Beine schwenken und gleichzeitig mit Pinzette an Kühler hochhalten.

Ich arbeitete da mit temperaturgeregelte Heißluftgerät Typ 1990-2/6 von Hazet für Autowerkstatt.
Dank passende (dünne) Düse ging bei mir schonend und weniger als 1 Minute raus. Beruflich bedingt könnte ich recht gut solcher Lötarbeit machen.

Kleine Hinweis, Beine von ADC ist etwas weich.

Grüss
Matt

 1 2 3 4 5
Wiederinbetriebnahme   Verzögerungszeitbasis   Tektronix   Extendet-Trigger-Fehlerdiagramm   Ersatzteilbeschaffung   Jitter-Ramp-Generator   Zuverlässigkeitsgründe   Leiterbahnenunterbrechung   Schieberegister-Ansteuerung   selbstverständlich   Spannungsfestigkeit   Durchkontaktierungen   Trigger   Leiterbahnen-Unterbrechung   spannungsgesteuertes   Triggereinstellungen   Elko-Pest   höchstwahrscheinlich   Sampling-Kondensatoren   funktioniert